← Back to archive

Why usage-based services need hard caps by default

At the beginning of this year, I had a pretty bad situation - one of my apps went into a loop and started burning tokens like crazy.

Luckily, I wasn’t far away, noticed it, and killed it before it drained the weekly budget.

That was a good experience because it helped me understand what usage-based services are really like - budget alerts won’t help in cases like this.

If an app or script can spend money easily, it’s important to have a hard cap by default.

Hit a $500 weekly/monthly limit? TURN IT OFF! Throw the error and kill the job.

You’ll get complaints from customers... yes for sure, but it’ll only take ~5–8 hours at most - much better than ending up with a +$50k bill, right? Once you see that error, you can connect to the server, run Claude to investigate, and push the update.

Now think about that - it could be even worse, because it might spin up additional AWS servers, call thousands and thousands of expensive models.

And what’s even more important is that it should be enabled by default on all providers. BTW, OpenAI added it only recently, and you could hit the limit pretty easily without it.

@fal is it possible to have monthly hard limit as we have it for AWS and OpenAI?

View on X

Why usage-based services need hard caps by default

Originally posted on X

PS: I'm pretty active on 𝕏 if you'd like to follow along

Archive

2026

2025

2024

2018